This iPhone app is from the future, asks you to upgrade to iOS 10.7 before you can use it [Image]

from_the_future_app

#epic #fail

(For those that don’t know, the latest iOS version currently is iOS 7 with iOS 7.1 right around the corner. We aren’t even close to iOS 10.7, yet.)

[via Reddit]

Share this post

Comments

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

1 comment