- dotTech - http://dottech.org -

Samsung Galaxy S III, Note II, and other devices are vulnerable to hackers due to Exynos 4 chip bug

Posted By Enrique Manalang On December 19, 2012 @ 12:52 AM In Android | 2 Comments

galaxys3 [1]

A serious security flaw has been found in one of Samsung’s Exynos chipsets, news that no Galaxy device user wants to hear. The flaw affects the Samsung Exynos 4, which means that Galaxy S III, Galaxy Note, Galaxy Note 2 and Galaxy 10.1 tablet users can all be potentially affected if a malicious hacker were to discover and exploit it.

An XDA forum member managed to identify this security flaw in the kernel, and it would allow attackers to bypass system permissions and gain access to RAM. Or, malicious code could be injected into the kernel. The developer also says that “it is easy to obtain root access on affected devices, with no control over it.”

There is hope, however. Looking into the issue further, it appears that another developer on the XDA forums has already created a fix for the exploit. XDA-Developer Chainfire has provided an apk that users can download and use to either root the phone using the exploit, or block the vulnerability on boot. The drawback to this solution is that if you choose to block the exploit, then the front camera of your Galaxy S III or Galaxy Note may stop working. Those worried about limiting their device’s functionality will be pleased to know that the apk can also be used to re-enable the exploit and regain full functionality, but only if your device is rooted.

With that said, it should be pretty obvious that this is simply a workaround and not a full-on fix for the problem. Here’s hoping that Samsung provides an official fix of their own before too long.

If you’re worried about the exploit right now however, you can find the download link at the XDA forum thread linked below!

XDA-Developer thread [2]

[via Fudzilla [3], Android Authority [4]]


Article printed from dotTech: http://dottech.org

URL to article: http://dottech.org/90584/samsung-galaxy-s-iii-note-ii-and-other-devices-are-vulnerable-to-hackers-due-to-exynos-4-chip-bug/

URLs in this post:

[1] Image: http://dottech.org/wp-content/uploads/2012/12/galaxys3.jpg

[2] XDA-Developer thread: http://www.xda-developers.com/android/dangerous-exynos-4-security-hole-demoed-and-plugged-by-chainfire/

[3] Fudzilla: http://www.fudzilla.com/home/item/29831-exploit-found-in-exynos-4-chips

[4] Android Authority: http://www.androidauthority.com/xda-developer-patches-samsung-exynos-chip-vulnerability-140742/

© 2008-2012 dotTech.org | All content is the property of its rightful owner.